Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Neon Certificate Spoofing and Denial of Service Vulnerability

Information

Severity

Severity

Medium

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

6.8

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

13 years ago

Modified

Modified

3 years ago

Summary

This host has Neon installed and is prone to Certificate Spoofing and Denial of Service vulnerability.

Insight

Insight

- When OpenSSL is used, neon does not properly handle a '&qt?&qt' character in a domain name in the 'subject&qts' Common Name (CN) field of an X.509 certificate via a crafted certificate issued by a legitimate Certification Authority. - When expat is used, neon does not properly detect recursion during entity expansion via a crafted XML document containing a large number of nested entity references.

Affected Software

Affected Software

WebDAV, Neon version prior to 0.28.6 on Linux.

Solution

Solution

Upgrade to version 0.28.6 or later.

Common Vulnerabilities and Exposures (CVE)