Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Perl Denial of Service Vulnerability Jan 2015 (Windows)

Information

Severity

Severity

Low

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

2.1

CVSSv2 Vector

CVSSv2 Vector

AV:L/AC:L/Au:N/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

8 years ago

Modified

Modified

4 years ago

Summary

This host is installed with Active Perl and is prone to denial of service vulnerability.

Insight

Insight

The flaw is due to improper handling of crafted input by Dumper method in Data::Dumper.

Affected Software

Affected Software

Perl versions 5.20.1 and earlier

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to 5.22.0 or later.

Common Vulnerabilities and Exposures (CVE)