Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PHP <= 5.6.27 / 7.0.x <= 7.0.12 DoS Vulnerability

Information

Severity

Severity

High

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

7.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Wont Fix

Created

Created

1 year ago

Modified

Modified

1 year ago

Summary

PHP is prone to a denial of service (DoS) vulnerability.

Insight

Insight

PHP mishandles property modification during __wakeup processing, which allows remote attackers to cause a denial of service or possibly have unspecified other impact via crafted serialized data, as demonstrated by Exception::__toString with DateInterval::__wakeup.

Affected Software

Affected Software

PHP versions through 5.6.27 and 7.0.x through 7.0.12.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

No known solution was made available for at least one year since the disclosure of this vulnerability. Likely none will be provided anymore. General solution options are to upgrade to a newer release, disable respective features, remove the product or replace the product by another one.

Common Vulnerabilities and Exposures (CVE)