Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL 10.x < 10.9, 11.x < 11.4 Buffer Overflow Vulnerability (Linux)

Information

Severity

Severity

Critical

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

9.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:C/I:C/A:C

Solution Type

Solution Type

Vendor Patch

Created

Created

3 years ago

Modified

Modified

3 years ago

Summary

PostgreSQL is prone to a stack-based buffer overflow vulnerability.

Affected Software

Affected Software

PostgreSQL version 10.x prior to 10.9 and 11.x prior to 11.4.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Update to version 10.9, 11.4 or later.

Common Vulnerabilities and Exposures (CVE)