Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL < 9.6.24, 10.x < 10.19, 11.x < 11.14, 12.x < 12.9, 13.x < 13.5, 14.x < 14.1 Multiple Vulnerabilities - Linux

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

4.3

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:N/I:P/A:N

Solution Type

Solution Type

Vendor Patch

Created

Created

1 year ago

Modified

Modified

1 year ago

Summary

PostgreSQL is prone to multiple vulnerabilities.

Insight

Insight

The following vulnerabilities exist: - CVE-2021-23214: Server processes unencrypted bytes from man-in-the-middle - CVE-2021-23222: libpq processes unencrypted bytes from man-in-the-middle

Affected Software

Affected Software

PostgreSQL prior to version 9.6.24, version 10.x through 10.18, 11.x through 11.13, 12.x through 12.8, 13.x through 13.4 and version 14.0.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Update to version 9.6.24, 10.19, 11.14, 12.9, 13.5, 14.1 or later.

Common Vulnerabilities and Exposures (CVE)