Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL Information Disclosure Vulnerability-Dec17 (Linux)

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

5.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:P/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

4 years ago

Modified

Modified

3 years ago

Summary

This host is running PostgreSQL and is prone to a information disclosure vulnerability.

Insight

Insight

The flaw exists as the functions json_populate_recordset and jsonb_populate_recordset are unable to handle malformed invalid input.

Affected Software

Affected Software

PostgreSQL version 9.3.x before 9.3.20, 9.4.x before 9.4.15, 9.5.x before 9.5.10, 9.6.x before 9.6.6 and 10.x before 10.1 on Linux.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to PostgreSQL version 10.1 or 9.6.6 or 9.5.10 or 9.4.15 or 9.3.20 or later.

Common Vulnerabilities and Exposures (CVE)