Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL 'Interactive Installer' Arbitrary Code Execution Vulnerability (Linux)

Information

Severity

Severity

Critical

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

9.3

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:C/I:C/A:C

Solution Type

Solution Type

Vendor Patch

Created

Created

3 years ago

Modified

Modified

3 years ago

Summary

This host is running PostgreSQL and is prone to arbitrary code execution vulnerability.

Insight

Insight

The flaw exists as interactive installer downloads software over plain HTTP and then executes it.

Affected Software

Affected Software

PostgreSQL versions 9.3.x prior to 9.3.15, 9.4.x prior to 9.4.10 and 9.5.x prior to 9.5.5 on Linux.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to PostgreSQL version 9.3.15 or 9.4.10 or 9.5.5 or later. Please see the references for more information.

Common Vulnerabilities and Exposures (CVE)