Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL Multiple Information Disclosure Vulnerabilities - May17 (Windows)

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

5.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:N/A:N

Solution Type

Solution Type

Vendor Patch

Created

Created

5 years ago

Modified

Modified

4 years ago

Summary

This host is running PostgreSQL and is prone to multiple information disclosure vulnerabilities.

Insight

Insight

Multiple flaws are due to, - Some selectivity estimation functions did not check user privileges before providing information from pg_statistic, possibly leaking information. - An error in 'pg_user_mappings' view.

Affected Software

Affected Software

PostgreSQL version before 9.2.21, 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6.3 on Windows.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to PostgreSQL version 9.2.21 or 9.3.17 or 9.4.12 or 9.5.7 or 9.6.3 or later.

Common Vulnerabilities and Exposures (CVE)