Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL 'xml_parse()' And 'xslt_process()' Multiple Vulnerabilities (Windows)

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

4.9

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:S/C:P/I:P/A:N

Solution Type

Solution Type

Vendor Patch

Created

Created

9 years ago

Modified

Modified

3 years ago

Summary

This host is installed with PostgreSQL and is prone to multiple vulnerabilities.

Insight

Insight

- An error exists within the 'xml_parse()' function when parsing DTD data within XML documents. - An error exists within the 'xslt_process()' when parsing XSLT style sheets.

Affected Software

Affected Software

PostgreSQL versions 8.3 before 8.3.20, 8.4 before 8.4.13, 9.0 before 9.0.9, and 9.1 before 9.1.5 on Windows

Solution

Solution

Upgrade to PostgreSQL 8.3.20, 8.4.13, 9.0.9 or 9.1.5 or later.

Common Vulnerabilities and Exposures (CVE)