Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Ruby on Rails Active Support Denial of Service Vulnerability (Windows)

Information

Severity

Severity

Medium

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

5.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

5 years ago

Modified

Modified

3 years ago

Summary

This host is running Ruby on Rails and is prone to denial of service vulnerability.

Insight

Insight

The flaw is due to Specially crafted XML documents can cause applications to raise a SystemStackError and potentially cause a denial of service attack.

Affected Software

Affected Software

Ruby on Rails before 4.1.11 and Ruby on Rails 4.2.x before 4.2.2 on Windows.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to Ruby on Rails 4.1.11, 4.2.2 or later.

Common Vulnerabilities and Exposures (CVE)