WeBid Multiple Cross Site Scripting And LDAP Injection Vulnerabilities

Published: 2014-07-29 07:23:33
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Summary:
This host is installed with WeBid and is prone to multiple cross site scripting and LDAP injection vVulnerabilities.

Detection Method:
Send a crafted data via HTTP POST request and check whether it is able to read cookie or not.

Technical Details:
Mulltiple flaws are due to, - The /WeBid/user_login.php script does not validate input to the 'username' POST parameter before returning it to users. - The register.php script does not validate input to the 'TPL_name', 'TPL_nick', ' TPL_email', 'TPL_year', 'TPL_address', 'TPL_city', 'TPL_prov', 'TPL_zip', 'TPL_phone', 'TPL_pp_email', 'TPL_authnet_id', 'TPL_authnet_pass', 'TPL_wordpay_id', 'TPL_toocheckout_id', and 'TPL_moneybookers_email' POST parameters before returning it to users. - An input passed via the 'js' parameter is not properly sanitized upon submission to the loader.php script.

Impact:
Successful exploitation will allow attacker to execute arbitrary HTML and script code in a user's browser session in the context of an affected site.

Affected Versions:
WeBid Version 1.1.1

Recommendations:
No known solution was made available for at least one year since the disclosure of this vulnerability. Likely none will be provided anymore. General solution options are to upgrade to a newer release, disable respective features, remove the product or replace the product by another one.

Solution Type:
Vendor will not fix

Detection Type:
Remote Vulnerability

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2014-5101
https://nvd.nist.gov/vuln/detail/CVE-2014-5114

References:

http://packetstormsecurity.com/files/127431

Search
Severity
High
CVSS Score
7.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.