Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Yahoo! Messenger 'YahooBridgeLib.dll' ActiveX Control DOS Vulnerability

Information

Severity

Severity

Medium

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

4.3

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

12 years ago

Modified

Modified

3 years ago

Summary

This host is installed with Yahoo! Messenger and is prone to a Denial of Service Vulnerability.

Insight

Insight

The flaw is due to a NULL pointer dereference error in 'RegisterMe()' method in 'YahooBridgeLib.dll', which can be exploited by causing the victim to visit a specially crafted web page.

Affected Software

Affected Software

Yahoo! Messenger version 9.x to 9.0.0.2162 on Windows.

Solution

Solution

Upgrade to Yahoo! Messenger version 10.0.0.1270 or later

Common Vulnerabilities and Exposures (CVE)